8.x

Drupal8 on-the-fly role-ba rendelés

edgarpe képe

Sziasztok!

Drupal8-ban megoldható szerintetek, hogy egy adott oldal letöltésekor (node edit form) a látogatót egyedi program logika alapján "beletegyem" egy role-ba, de csak az adott oldal letöltéséig? Magyarul én szeretném dinamikusan eldönteni, hogy egy user tagja-e egy role-nak vagy sem.

Drupal verzió: 
Melyik modulhoz, modulokhoz kapcsolódik a téma?: 

Entity Reference Field - Unique validáció

ssibal képe

Sziasztok!

A következő feladattal állok szemben:

Szeretném, ha egy multiple (1..*) entity reference field potenciális értékei egymáshoz mérten egyediek volnának. Fontos, hogy ezt field szinten szeretném elvégezni (nem hook_form_alter-al), mivel általában szükség van a funkcióra, és nem csak bizonyos űrlapokon.

Az ehhez kapcsolódó plugin field type, amit találtam:

EntityReferenceItem

Drupal verzió: 

Parent Entity Type - Lehetséges?

ssibal képe

Issue:

Van 7 darab különböző node type-om (article fajták), melyek fieldj-jei 90%-ban megegyeznek, mind field base, mind field instance téren (ergo a field instancek azonosan vannak felparaméterezve).

Probléma:

Amennyiben szeretnék új közös field-et felvenni, azt 7-szer kell megtennem, ha label szerű változtatás kell, azt is 7-szer kell, nem beszélve a form_alterkről, ahol 7db form_id-t kell megcímeznem.

Álom megoldás:

Fórum: 
Drupal verzió: 
Melyik modulhoz, modulokhoz kapcsolódik a téma?: 

Drupal 8 tárhely, hosting

rh04 képe

Szeretnék szert tenni egy korrekt Drupal 8 tárhelyre, ahol előtelepített Drupal 8-at kaphatok különösebb korlátozásoktól mentesen. Egy domainnév lenne, egy oldal menne rajta csak.

Csodás lenne, ha mindezek (és más alapvető funkciók is) alapértelmezetten működnének, rendelkezésre állnának:
- clean urls
- ssl certificate/https
- ftp
- modulok, sminkek telepítése nem ütközik akadályba
- a frissítések nem ütköznek akadályba

Drupal verzió: 
Taxonomy upgrade extras: 

Drupal 8 telepítés rendben, működés nulla

DruTa képe

Üdv!

Egy fizetős tárhelyre telepítettem a D8-at, legfrissebb verziót. Az Apache verzióját nem ismerte fel a telepítő, de megnéztem a cPanelben és rendben van, és a "opcache" PHP modult kérte, azt engedélyeztem és simán lement a telepítést, meg is jelent az oldal, ahogy kell, de onnantól kezdve a "Kezelés" és "Gyorshivatkozások" menü kivételével bármilyen menüre kattintok, kiesik az oldal és az alábbi hibaüzenet jön:

Drupal verzió: 

Drupal 7 -> Drupal 8 migrálás

agostonl képe

Sziasztok!

Nézegetem a leírásokat, de nekem az jön le, hogy a D7-D8 migrálás még nem az igazi, de javítsatok ki, ha tévedek!

Ha jól látom jó pár dolgot, pl. Views, nem visz át a migráció.

Drupal verzió: 

Composer manager

mattil képe

A Drupal Commerce kipróbálása miatt szükség lenne a composerre és a címben jelölt modulra. Odáig eljutottam, hogy az itt lévő leírásnak megfelelően az init php-t elindítottam. Meg is jelent az "Composer Manager has been successfully initialized." szöveg, az állapotjelentésben is változott a hibajelentés.
A következő lépésnél viszont a "composer drupal-update" parancsot beírva azt mondja hogy
"No command 'composer' found, did you mean:
Command 'compose' from package 'mime-support' (main)

Drupal verzió: 
Melyik modulhoz, modulokhoz kapcsolódik a téma?: 

Drupal8-ra nincsenek felkészülve a hazai szolgáltatók

mattil képe

"Your PHP installation is too old. Drupal requires at least PHP 5.5.9. See the system requirements page for more information."
Elkezdtem a korábban általam készített weblapokat átírni az új Drupal verzióra, de egyelőre ezt kapom a legtöbb hazai tárhelyszolgáltatótól vissza, ha telepíteni szeretném a 8-ast. Fizetősektől, ingyenesektől is. És állítólag én vagyok eddig az egyetlen aki ezt hiányolta..

Drupal verzió: