Windows 7 64-bitre Drupalt!

pityu73 képe

Sziasztok!
Az alábbi hibához keresek megoldást:
Egy tesztkörnyetetet kell létrehoznom Win7 64-bites rendszeren.
Letőltőttem a XAMPP 1.7.1 verzióját, a drupal 6.16 és a hozzátartozó nyelvi fájlt.
Eddig minden simán ment szépen beállítottam minden Xampp által elinditott programot rendszergazdai futásra nehogy probléma legyen.
A telepítések sem okoztak problémát, de a drupál telepítése után egyből mentem az állapot jelentés oldalra és ezt a hiba üzenetet kapom:
HTTP kérés állapota Nem sikerült
A rendszer vagy a hálózat beállításai nem teszik lehetővé hogy a Drupal weboldalakat érjen el, ami csökkentett működést eredményez. A hiba oka webszerver vagy PHP beállítás lehet és javasolt kijavítani, hogy működjön a rendelkezésre álló frissítési információk letöltése, hírcsatornák betöltése, OpenID felhasználásával történő belépés vagy más hálózat függő szolgáltatás.

Azt értem miket kell megnézni, de nincs rutinom ezek beállítására. Mindenem fut, de ez a hibaüzenet zavar. Ha valakinek van tapasztalata WIN7 64-bit téren azt megköszönöm.

Egy tanfolyamhoz kelle a tesztkörnyezet kialakítása amire jelentkeztem hozzáteszem nem nagyon van lehetőségem másik rendszer elinditására.

Köszönettel:
István

Drupal verzió: 
nevergone képe

elég fura hiba, a tanfolyam-vezetőt kérdezted?

0
0
pityu73 képe

Igen, azt monta még nincs tapasztalat WIN7 64bit alatt, de nem is csodálom ez is csak én lehetek aki ezen probálkozik.

0
0
drifter képe

Nincs valami telepített tűzfalad, ami letiltja hogy a php-apache kifelé kérjen a 80-as porton?

0
0
pityu73 képe

Megnéztem a "Vezérlőpult\Rendszer és biztonság\Windows tűzfal\Engedélyezett programok"-nál és ott bejelőltem egyesével az idetartozó programokat, hogy engedje ki de nem találtam meg melyik az amelyiket fogja.

0
0
sgabe képe

Előfordul, hogy az üzenet fals pozitív és akkor is dobja a rendszer, ha valójában nincs gond. Lásd az erről szóló issue-t vagy GYIK-ot. A D7-ben már kikapcsolható lesz, D6-hoz van egy modul vagy patch.

update: a thread címét módosítani lehetne valami beszédesebbre

0
0
Ave képe

Talán hasznos információ lehet. Én Vista 64-bitre telepítettem a XAMPP-ot. Nekem a Skype-nál kellett állítanom, hogy ne használja a 80-as portot.

0
0
pityu73 képe

Köszönöm a segítséget egész nap olvastam az idetartozó hozzászolásokat amit ajánlottál, de egyelőre a modul lett a megoldás mert eltünt a hiba üzenet.

A modult beállítottam 5 perces futásra. Nem tudom számít-e valamit.
De még sem ad 100%-os megoldást mert....
Meg néztem a hiba naplót miután néha felugrik ez a kimenet:
Hely: http: //localhost/DRUPAL/admin/reports/status/run-cron
$fails = FALSE

A naplóból részlet:
Hely: http: //localhost/DRUPAL/admin/reports/status/run-cron
Hivatkozó: http: //localhost/DRUPAL/admin/reports/status
Üzenet Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\DRUPAL\modules\http_request_fail_reset\http_request_fail_reset.module:15) - C:\xampp\htdocs\DRUPAL\includes\common.inc - 345. sor.
Szint: hiba

Az értem hogy a common.inc-nél van a hiba és ez a link is erre utal. Sajnos gyenge angol tudásom csak azt vettem ki, hogy leírja mi a hibás kód rész: amit persze nem találtam meg a saját common.inc fájlomban csak egy részletét.
Ha jol értelmeztem akkor ki kéne kommenteznem a hibás részt és be kéne írnom a javított változatot.

Nálam 345 sor= header('Location: '. $url, TRUE, $http_response_code);
Ezt csak azért irtam ide a pontositás kedvéért, de a belinkelt cikknél másról beszél ami lehet a megoldás modul nélkül is.

Mit mire ez itt a kérdésem hogy ezt is kiprobáljam mint egy második lehetőség.

0
0
teecee képe

... Win7 Ultimate megyar, 64biten pöccre.
Egyik ismerősöm jelezte, hogy neki Vista alatt voltak problémái, nekem megy jól a XAMPP 1.7.1
Annyi valóban volt, hogy az apacs 80-as porton szeretne elindulni és néha (?!) a Skype lefogja magának ezt a portot, szóval Skype kikapcs, XAMPP Panelen Apache start és utána Skype start, a programok is örülnek és én is...

Win7 64bit-re az Acquia Drupal nem jó? Azt pont Drupalhoz készült telepítő minden hozzávalóval, Win Mac és még Deb alá is ha jól emlékszem. (Én nem használtam sose', hardcore PHP-s vagyok, évek óta beröffentett XAMPP-on dolgozom :D)

0
0

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
TeeCee, the One and Only

Paal képe

Skype esetében: Eszközök/Beállítások/Speciális/Kapcsolat és kikapcsolod „A 80-as vagy a 443-as port is használható a bejövő hívásokhoz” beállítást... :)
(korábban én is így csináltam amúgy)

0
0

--
Palócz Paal Pál, a drupal.hu admin csoportjának tagja
Ajánlott olvasmány: Eric Steven Raymond - Hogyan kérdezzünk okosan

Nagy Gusztáv képe

elmondom, hogy ennek itt, egy tanuló környezet esetén nem nagyon lesz jelentősége. Lesz néhány funkció, ami nem fog menni, de ez nem nagy gond.

Még két megjegyzés:

  1. Ez még nem volt feladat, várd meg, amíg oda érünk.
  2. A tanfolyamhoz kapcsolódó, ehhez hasonló kérdéseket egyenlőre a tanfolyamon belül beszéljük meg
0
0

Nagy Gusztáv

(Ha most kezded, az ingyenes Drupal 7 alapismeretek könyvem hasznos lehet.)

pityu73 képe

Ennyivel tartozom az útánam jövőknek és a segítőknek.
Miután "sgabe"-től kaptam jó kis kutató munkát és tesztelési lehetőséget amivel még sem jutottam el a 100%-ig így tovább kutattam.
Mivel Skype-t nem használok, és a tűzfalam sem tíltotta le az apache-t gyorsan át is lépten rajta, de a port probléma mégsem hagyott nyugodni. Így kerestem egy programot ami szépen megmutatta melyik portot mi használja és láss csodát a LogMeIn.exe ott csücsült a 80-as porton.
Innen már egyértelmü volt a megoldás a sikerhez:
- Modul kikapcsol
- Apache leállít
- LogMein leállít
- Apache elindít
- Logmei elindít
Gyors ellenőrzés a portokon (itt megjegyezném amit utolag megtudtam parancssorból: "netstat -abn" parancsal szintén ellenőrizhető) mindenki a helyén.
Mehet a tesztelés!.........és működik.

Köszönöm a segítséget, és remélem tudtam segíteni aki színtén ennek a triónak a hálójába esik (Win7 64-bit, Drupal 6.16, és LogMeIn).

u.i.: 1.Ez még nem volt feladat, várd meg, amíg oda érünk. Egy defektes rendszerrel meddig jutnák? Vizuális tipus vagyok muszály, hogy minden működjön.

0
0
tamoca képe

Jó napot mindenkinek!
Én is W7 64 et használok. Van valakinek hosszabb tapasztalata? Mármint ,hogy feltette az XAMPP -ot(áprilisban)és utána használta is egy darabig már? És esetleg fut együtt Ubuntuval Vmware-vel?

0
0

tamoca

pityu73 képe

Nekem azóta megy és a teszt weplapjaim is localhoston. Ubnutus kérdésedet én még nem használom.

0
0
tamoca képe

Köszi a gyors választ.

0
0

tamoca

nevergone képe

Ez egy teljesen más téma, légyszíves ne keverjük ide.
Azt pedig nem értem, hogy az Ubuntura és a Vmware-re mi a szükség, ha egyszer XAMPP-ot használsz.

0
0
tamoca képe

Jó estét!
Indítottam is ezt új témaként, de köszi itt megjött a válasz, hogy műkszik.
Az igazi az lenne , hogy ha nem kellene kikapcsolnom a gépet a két oprendszer váltása közt. Emiatt maradok a xampp w7 nél, mert napközben az kell többnyire.

0
0

tamoca

matyus10 képe

Szintén Windows 7 64 bit.
Nem jövök rá a problémára. Követtem az utasításokat, amit itt olvastam. cmd: netstat -abn , nincs 80-as porton semmi. Elindítom a Control Panelt és hiába kattintok a startra, mind apache-nál és mysql-nél, nem lesz aktív. Néha csak egy pillanatra, kivillan, aztán leáll.

Tűzfal: comodot használok, de ki van engedve a progi, a windows tűzfalon is átengedtem.
Van routerem, és három gép van az itthoni hálózatban, de úgy tudom, ez nem lehet gond.

Az XAMPP-on kívüli összes többi progi kényes erre a portos játszadozásra?
Esetleg az újabb XAMPP- okon ezt a hibát kijavították már?

A választ előre is köszönöm. :) Kicsit idegesít, hogy itt az elején elakadok, már rá ment az egész napom :)

UI: Időközben azt sikerült kiderítenem az XAMPP frissebb verziójával, hogy a 80-as porton valami mégis fut, de csak annyit tudok, hogy a rendszer használja.
Ezt írja ki port ellenőrzéskor:
Apache (HTTP) 80 Process: System

0
0
pityu73 képe

Új téma, új téma itt ez a szokás.
De ne maradjál itt se válasz nélkül a rendszergazdai módot is engedélyezted, a program futásánál?

0
0
matyus10 képe

Elnézést, azt hittem, hogy még ebben a témában vagyok. :) Akkor eltévedtem.
Igen, természetesen ez megtörtént. A helyzet, hogy azt sikerült elérnem, hogy legalább a mysql fut. Bár ez csak fél siker. A windowos tűzfal paradoxon tréfált meg, teljesen kikapcsoltam (kár, hogy nem lehet uninstall-álni).
Ennek ellenére az apache továbbra sem, akar engedelmeskedni az újabb verzióval sem. :(

0
0
pityu73 képe

Igen a téma megfelelő, de lehet a te problémád egyedi és ha végtelenítjük a szálakat egy adott témánál akkor a megoldás elveszik a nagy számok törvényében. Így aki szintén a te cipődben jár az már nem fog idáig eljutni az olvasással és válaszolatlanúl marad. Ha új témaként teszed fel akkor lehet 2-3 válasszal már megoldódik a problémád és ha ezt még egy zárszóval is megspékeled akkor teljes az öröm, mert nem csak te jutottál el a sikerhez hanem másokat is magaddal vittél.

0
0
matyus10 képe

Még egyszer elnézést. De engedjétek meg, ha már ide írtam, hogy irhassak ide egy zárást a problémámra. Sikerült megoldanom a helyzetet. Win7 mellé, körülbelül fél óra alatt felpakoltam az ubuntut, kb. negyed óra frissítés, és fél óra, linux újra megismerés után, hosszas egy órámba került, mire minden perfekült beüzemelődött. Ehhez nagyon szépen köszönöm Nagy Gusztáv jegyzeteinek segítségét, és abban található lábjegyzetben megemlített linket: http://www.tanarurkerem.hu/node/104
Érdekesség, hogy így sokkal könnyebb mindent konfigolni, és aki win7-tel szenved, javaslom, gyorsan próbálja ki ubuntut. Megéri azt a pár óra ráfordítást. (Amúgy próbálkoztam tovább win7-en is, minden lehetséges system alkalmazást kilőttem feladatkezelőből, de az apache nem indult.) Egyetlen megoldás a win7 újratelepítése, de nekem ahhoz nincs kedvem, se időm, se türelmem :)

0
0
tamoca képe

Azért írom mert többször ezt tapasztalom.
A skype beállítások menü
speciális
kapcsolat
vedd ki a pipát a 80-as porttól és a bejövőhöz 5648-at írj és már megy is.
Egyébként win7 64 re megy az xampp kitűnően.
Üdv mindenkinek.

0
0

tamoca

plastilin képe

Az idők során pár problémába belefutottam ezen a téren, ezért mind elmesélem:

Futtasd rendszergazdaként
Indulás után, még mielőtt bármit elindítanál, nyomsz egy jobbklikket a XAMPP Control Panelen, futtatás rendszergazdaként. És bizakodj, hogy nem autostartos, hanem feltételfüggő az a szolgáltatás, ami korábban megfogta a portot

Skype (ez már volt, ha jól láttam, de ismétlés a tudás hogyhíjjákja :-))
\Beállítások
\Speciális
\Kapcsolat,
majd szüntesd meg a jelölést a "A 80-as vagy 443-as port is..." bejegyzésnél.
Skype restart.

Teamviewer
\Extrák
\Beállítások
\Haladó,
majd "Haladó beállítások megtekintése", keresd ki a "Haladó hálózati beállítások" majd jelöld be a "Ne használja a bejövő 80-as portot..." bejegyzésnél.
Gép restart.

Telepítsd a szolgáltatásokat...
XAMPP Control Panelben lehetőség van beállítani autostartosra az apache-ot, mysqlt, ftp, mercury-t, tomcat-et. És bizakodj, hogy előbb indulnak, mint az a szolgáltatás, ami korábban mindig megfogta a portot.

Még mindig nem megy! [apache] Port 80 in use by "system"! 1.
Feltételezhetően fut az ISS. Az én megoldásom az lenne, hogy az ISS-t leállítanám és leszedném.
\Vezérlőpult\Minden vezérlőpultelem (tehát kategórianézet ki van kapcsolva)
\Programok és szolgáltatások,
majd Windows-szolgáltatások be és kikapcsolása" az ablakban szüntesd meg a jelölést az "Internet Information Services" bejegyzésnél.

Még mindig nem megy! [apache] Port 80 in use by "system"! 2.
A httpd.conf-ban keresd ki a "Listen"-nel foglalkozó szakaszt és írd be egy önálló sorba:
Listen:"kívánt port"
(természetesen idézőjelek nélkül).
Nálam 8080 lett, tehát az url-jeim így néznek ki: "http://localhost:8080/projectneve...".
Ezt a rettentően nehéz url megadást persze le lehetne egyszerűsíteni, egy elég bonyolult műveletsorral, úgy, hogy belenyúl a az ember a névfeloldásba és az apache virtual host beállításaiba.
Ehhez "mindössze" a \windows\system32\drivers\etc alatt található "hosts" fájhoz (igen, így, mert valóban nincs kiterjesztése! (és többnyire írási jogod sincs rá!)) kell egy sort hozzáadni, illetve a \xampp\apache\conf\extra alatt található "httpd-vhosts.conf" fájlhoz... hát... nagyjából félmaréknyit...

1
0
Sk8erPeter képe

Kicsit túlzás, hogy olyan hű de bonyolult lenne Apache-on a VirtualHost beállítása, miután a %SYSTEMROOT%\system32\drivers\etc\hosts fájlhoz hozzáadtad pl. a

127.0.0.1       tesztdrupal.local

sort.
Nagyon régen konfigoltam Apache-ot, de mindössze ennyi konfigurálni a tesztdrupal.local címhez tartozó VirtualHostot:

  1. ## Tesztcélú Drupal
  2. <VirtualHost 127.0.0.1>
  3. ServerName tesztdrupal.local
  4. DocumentRoot "d:/Projects/PHP/tesztdrupal/public_html"
  5. <Directory "d:/Projects/PHP/tesztdrupal/public_html">
  6. Options All
  7. AllowOverride All
  8. Order allow,deny
  9. Allow from all
  10. </Directory>
  11. </VirtualHost>

Ez azért nem olyan nagyon hosszú.

De ami ennél is fontosabb: Windows-on nem feltétlenül kell erőltetni az Apache-ot. Csak akkor, ha valaki nagyon ragaszkodik hozzá, hogy az éles környezethez hasonlóban tesztelje Windows alatt is a Drupalját, és az éles környezeten Apache van.

De Windows-on érdemes IIS-t és FastCGI PHP-t használni, mindezt a Web Platform Installer segítségével nagyon egyszerűen, kattintgatós módszerrel lehet telepíteni. A teljesítményével sincs probléma.
Sőt, még egyszerűbb: Web Platform Installer segítségével egyszerűen beírjátok a keresőbe, hogy "Drupal", felajánlja egyből az Acquia Drupalt, majd ha az Add-re kattintotok, a WPI behúz magától mindenféle függőséget: MySQL-t, PHP-t, Windows Cache Extensiont, stb.
Én elég régóta használom így localhoston a telepített Drupaljaimat.

Web Platform Installer + Drupal

2
0
plastilin képe

Igen, közben nekem is ez a remek megoldás jutott eszembe, ha joga van az embernek telepíteni bármit: hagyni a francba a XAMPP-ot, és feltenni egy Acquia-t (ez ugye nem reklám?). Ezzel egyetlen egy lépésben minden akadályt át lehet ugrani.

0
0
Sk8erPeter képe

Nem muszáj feltétlenül Acquia Drupalt használni ezek után, de első körben mindenképp leegyszerűsíti a dolgodat annyiban, hogy lehúzza az összes, Drupalhoz szükséges függőséget, a UNIX/Linuxos konzolon telepítős módszerekhez hasonlóan (mint amikor UNIX/Linux konzolon beírod, hogy telepítse a phpMyAdmint, akkor ott is behúzza a függőségeket, Apache-ot, MySQL-t, stb.; valószínűleg innen jött az ötlet). Ezek után ezt a Drupalt persze nyugodtan törölheted is, aztán felrakhatsz olyat, amilyet csak szeretnél.

0
0