warning: update.php on line 616.

Anonymous képe

Sziasztok!

Rákerestem erre a hibaüzenetre a neten, de pont erről nem találtam semmit.

Éppen bekapcsoltam egy alap modult, ami után lefuttattam az update.php-t és most először fordult elő, hogy hibaüzenet jött, pedig hónapok óta nyúzom a drupalt különféle teszt telepítéseken:

warning: ini_set() has been disabled for security reasons in ***** update.php on line 616.

A *-ok helyén a mappa elérési útja van.

Válasz helyett az is jó, ha tudtok mutatni egy helyet, ahol a hibaüzenetek magyarázatai találhatóak (ha van ilyen), mint a Windowsban is.

Drupal verzió: 
nevergone képe

bekapcsoltam egy alap modult

Melyiket?

ami után lefuttattam az update.php-t

Új modul bekapcsolásakor nem kell, amúgy pontosan melyik Drupal verzió?

warning: ini_set() has been disabled for security reasons in ***** update.php on line 616.

És mi található az update.php 616. sorában?

ahol a hibaüzenetek magyarázatai találhatóak (ha van ilyen)

Sajnos attól tartok, hogy nincs, amúgy ez egy elég informatív hibaüzenet.

Milyen tárhelyen, milyen PHP verzióval futtatod a Drupalt?

0
0
vacati képe

A Friss tartalmak modult kapcsoltam be, de szerintem nem ez az ok.

Hát akkor mikor kell az update.php-t futtatni?

A 616-os sorban gondolom mindenkinek ugyanaz van, de igaz, inkább beidézem:

ini_set('display_errors', TRUE);

A tárhely egy fizetős tárhely, eddig nem volt vele drupal szempontból baj.

PHP: 5.2.14

Valami "odakerült" a gyökérmappámba, amit eddig nem láttam:

.wysiwygPro_preview_fd491768bbe8b2f208d6e5d82758228a.php

A tartalma:

if ($_GET['randomId'] != "tq97udUNRh71oyBa201OM96TMUuRgAgWfWC9EuODNVwhM_u6SQe0kAglb2G1ZW8t") {
echo "Access Denied";
exit();
}
 
// display the HTML code:
echo stripslashes($_POST['wproPreviewHTML']);

Ennyi a gyanúm.

0
0
nevergone képe

Hát akkor mikor kell az update.php-t futtatni?

admin/build/modules oldal:

Az update.php fájlt minden modul frissítés után futtatni kell.

Nagy Gusztáv jegyzete, 65. oldal:

Itt akkor lehet hibajelzésünk, ha az oldalunkat frissítettük egy újabb kiadásra, de az ilyenkor kötelező update.php futtatás elmaradt.

Valami "odakerült" a gyökérmappámba, amit eddig nem láttam: .wysiwygPro_preview_fd491768bbe8b2f208d6e5d82758228a.php

Bár nem tudom, hogy milyen modulokat és szerkesztőt használsz, de szerintem az törölhető, semmi keresnivalója nincs ott. Szerintem válts FTP klienst és nézz körül a logokban, mert illetéktelenek hozzáférnek az oldaladhoz.

0
0
vacati képe

Válaszoltak: szerintük veszélyes az a php függvény, ezért letiltották, de szerintük nem kellene ezért hibát jeleznie a Drupalnak.

FileZilla jó lesz?

Egyébként mit csinál az a beidézett furcsa file?

0
0
csakiistvan képe

winscp, és úgy tárold az összes ilyen kliensben a jelszót hogy odabiggyesztesz 1-2 karaktert, amit csak te tudsz. pl a végére egy "...._3" és a kártékony vírus máris nem tud vele mit kezdeni, de ha te be akarsz jelentkezni tudod hogy honnan, és mennyi karaktert kell az ál jelszóból törölni hogy az működjön is.

0
0

-
Features, drush, git... ne nélkülözd őket

vacati képe

És az "ini", amit letiltott a szolgáltató, az kell a drupalnak, vagy sem?

És mit csinál a fent beidézett file? Valami csúnyaságot?

Ez biztonságossá teszi a TC-t? http://www.inter.hu/faq.php?content=23

0
0