Eseménynapló: 2 db figyelmeztetés fajta?

Anonymous képe

Sziasztok!

Az eseménynaplózás során vettem észre, hogy a SZINT résznél ismétlődik a FIGYELMEZTETÉS kiválasztásának lehetősége, azaz kétszer szerepel a listában. Az egyiket kiválasztva megjelennek a figyelmeztetések, a másiknál nem.

Fordítási hiba, vagy véletlenül kétszer került bele ez a rész?

Kitöröltem a Watchdog-ot, hogy ürítsem az eseménynaplót (ne zavarjon a sok bejegyzés) és elkezdtem újabb eseményeket csinálni, ami valószínűleg figyelmeztetési eredményt hoz, de akkor is csak az egyik működik.

99%, hogy ez egy halott listaelem...

Drupal verzió: 
Balogh Zoltán képe

Fogtál egy fordítási bugot, kösz. Jelenleg az alert és a warning fordítása is figyelmeztetés, de ez nem egy halott listaelem. Így viszont kéne egy jó magyar szó az alert-re, ami a súlyosságot tekintve a vészeset és a kritikus hiba közé illik (és nem figyelmeztetés). Elég sok modulban szerepel ez a szó, úgyhogy jól gondoljuk át, mi másnak fordítsuk. A riasztás elmegy?

0
0
rendszereto képe

Ez magyarul annyit tesz, hogy a fordítás során két különböző kifejezéshez ugyan azt a magyar szót párosították? Tehát akkor ez máshol is megjelenik, ahol ezt a szókapcsolatot alkalmazták?

Amikor fordítják a szöveget, akkor úgy kell elképzelni, hogy bal oldalon egy listában felsorolják az elforduló angol mondatokat, szavakat és mellé biggyesztik annak a megfelelőjét, azaz vakon megy a fordítás, vagy abban a pillanatban látja is az illető, hogy melyik menüben, milyen felületen található az adott rész?

Mert ha az előbbi, akkor kész csoda, hogy csak ilyen kevés hiba van benne.

Ami a szót illeti: jobban ismerni kellene ehhez a rendszert, csak így a szavakat nézve a Vészeset és a Kritikus hiba is elég közel áll egymáshoz, még közé is tenni egy szót...

Talán a legegyszerűbb, ha egyszerűen Riasztás-nak nevezzük.
Mert az nem vészeset és nem is kritikus hiba, viszont fontosabb, mint egy sima figyelmeztetés.

0
0
Balogh Zoltán képe

A fordítás menetéről külön főmenüpont van. Sokféleképpen lehet, úgy is, ahogy elképzelted, de lehet akár közvetlenül a weblapon is.

Kösz a jelzést, ha látsz még hasonlót, ne kímélj.

0
0
rendszereto képe

É ez a javítás akkor már a hathuszas gyorsban benne lesz?

UI: Azt hiszem töröltetem a regemet, mert most már minden hozzászólásomnál kéri a verification kódot és ÚÚÚÚÚÚÚÚNOM!

0
0
Balogh Zoltán képe

Ha exportálod magadnak az l.d.o-ról a Drupal core 6.19 aktuális fordítását, majd a saját honlapodon felülíró módban importálod, akkor Nálad is meg fog jelenni, azonnal.

0
0
rendszereto képe

Ha exportálod magadnak az l.d.o-ról a Drupal core 6.19 aktuális fordítását

l.d.o? Az mi?

Egyébként itt a drupal.hu főoldalán lévő fordítási file-ban nem lesz frissítve?

0
0
nevergone képe

http://localize.drupal.org/

Itt csatlakozhatsz a hazai fordítási csapathoz, nyomon követheted a fordításokat, stb. :)

0
0
rendszereto képe

A november 3-i frissítést importáltam és ki is írta a rendszer, hogy mennyi új került be és mennyit frissített, sőt, kétszer is megcsináltam, de semmi. Maradt nálam kétszer a figyelmeztetés szó, a riasztás nem jelent meg.

Igen, az l.d.o-ról, a 6.19-es verziót mentettem le
Igen, felülíró módban importáltam

2Y6HW (tiltakozásul, hogy minden hozzászólásomnál Word verification kódot kell beírnom, ide írom az aktuális kódot, amíg ez a dolog nem változik. Írtam a rendszergazdáknak is e-mailt több napja, de nem kaptam választ.

0
0
Balogh Zoltán képe

Szerinted, ha Te egy november 3-i változattal dolgozol, de én a hozzászólásom dátumából következően csak 4-én írtam át az l.d.o. adatbázisában, akkor vajon mi lehet a baj?

0
0
rendszereto képe

1. Mondat, hogy frissítve lett
2. Onnan töltöttem le, ahonnan mondtad
3. A dátum novemberi és most, november elején beszéltünk erről

Tehát ha hibáztam, maximum abban, hogy hittem neked és nem ellenőriztelek le.

Egyébként "köszönöm" az indokolatlan le...szást! Nagyon "szimpatikus" ez a fennsőbbséges stílus... Meghozza ez az ember kedvét, hogy beletegyen valamit is a közösbe.

Megmutatom, milyen egy intelligens válasz:

Szia rendszerető!

Azon az oldalon, ahol mondtam, hogy letöltheted a legfrissebb változatot egy november 3-i változat van, mivel mi az után beszéltünk itt, ezért ebben még az a javítás nem lehet benne.

1. variáció, ha az a helyzet, hogy ott van az, csak máshol:

Bocs, hogy nem volt egyértelmű, hogy hol található a legfrissebb verzió.

2. variáció, ha az a helyzet, hogy az ígéreted ellenére nem tetted fel a frissítést:

Bocs, igaz, hogy azt írtam, hogy már frissítettem, de nem volt még időm!

0
0
aries képe

Nyugodj meg és gondold végig. Jeleztél egy fordítási hibát, amit Zoli még aznap javított, de te ennek ellenére egy korábbi fordítási fájlt töltöttél le véletlenül. (Egy olyat, amelyik régebbi mint ahogy a hibát jelezted volna.) Emiatt kár bevágni a durcát.

0
0
aries képe

Amikor átnézzük a fordítást, akkor szinte biztos, hogy vakon tesszük. Amikor meg fordítunk, hiába ismeri az ember a modult, nem mindig van lehetőség egyesével megnézni, hogy pontosan hol fordul még elő. A helyzetet bonyolítja, hogy egy-egy kifejezést két külön modul is használhat, és ha az egyikben már előbb le lett valahogy fordítva, és ott megfelelt, akkor a másiknál lehet, hogy már csak az új kifejezések lesznek lefordítva vagy átnézve.

0
0
aboros képe

warning: makula
alert: gyász

a makulamentes és a begyászolódott kifejezésekből deriváltam :)

0
0

-
clear: both;

vacati képe

Sziasztok!

A 6.20-as verzióban megint két darab figyelmeztetés van. Pedig amikor itt kijavítottátok, akkor a 6.19-ben rendesen riasztás volt.

Hogy lehet?

0
0
Balogh Zoltán képe

hogy a címlapon elérhető fordítás NEM naprakész. A jelenleg letölthető változat éppen a 2010. október 13-i állapotot tükrözi. Ne onnan szedd a honosítást, hanem az l.d.o-ról közvetlenül, vagy használd az l10n_update modult, és akkor rendben lesz.

0
0
vacati képe

valószínűleg a 6.19-eshez máshonnan szedtem le?!

Azért logikus lenne, hogy a főoldalon lévő friss legyen, legalábbis ne 3 hónapos.

0
0
nevergone képe

Én pedig erre mondhatnám, hogy aki még mindig a drupal.hu-ról tölti a fordítást és nem használja az l10n_update-t vagy az l10n_install-t, sikeres ember nem lehet. :)

0
0
vacati képe

Másrészt szeretem, ha én döntöm el, mikor változzon valami a rendszerben, ne egy automatizmus :-)

0
0
nevergone képe

Próbáld ki az l10n_update-t és rájössz, hogy semmi sem automatikus: Jelez, ha új fordítások vannak és ugyanott rögtön le is töltheted őket, de ez utóbbit nem teszi meg automatikusan helyetted.
Persze ez a tapasztalatod már meglenne, ha egy tesztoldalon megnézted volna. :) Másrészt pedig ez alapján az l10n_install is a végleges Drupal 7-et tartalmazza. :)

0
0
vacati képe

Valami oknál fogva szeretem minél egyszerűbben, tisztábban használni pl. a Drupalt, ezért csak a tényleg szükséges modulokat telepítem.
Van ennek az ellenkezője is: sokan szeretnek mindent feltenni, amit csak lehet.

Egyszer egy önlejölt dtp-snél jártam, vagy 10 éve, és úgy tele volt a számítógépes Windows asztala (persze lopott) programokkal, hogy nem is volt már több hely szinte.

Ezt azóta sem felejtettem el, annyira negatív benyomás volt.
Persze sokan használnak illegális szoftvereket, de ez az ember aztán tényleg túlzásba vitte és az volt a visszataszító a dologban, hogy egy profi képében tetszelgett, akinek nagyon megvan minden szükséges dolga a jó munkához.

Régebben nekem is volt egy két olyan programom, aminek a próbaideje már többször lejárt, de most már nincs, és tök jó érzés. Addig nem is érzetem magam igazi vállalkozónak.
Amióta legális minden és EVA-s vagyok, azaz mindent befizetek adót, amit kell, úgy érzem jogom is van arra, hogy kifogásoljak dolgokat a társadalmunkban és nem érzem magam már piti vállalkozónak.

Igaz egy program van, aminek a meg nem vételére szólítanék fel mindenkit, mert elképesztően drágán adja nekünk a sz.rt, nem úgy, mint az USA-beli honfitársainak. Ez egy olyan program, amit a géppel adnak sokszor, nekem is azért lett csak megvéve, de a dobozost szeretném, emberi áron.

Na de bocs, hogy elkalandoztam: lényeg: minél kisebb Drupalt akarok használni.

De kösz a javaslatot!

0
0
nevergone képe

Van különbség, amikor egy modul csak azért van fent az oldalon "mert csak", esetleg az általa megvalósított dolgokat a már meglevő eszközökkel is meg lehetne valósítani. Illetve van az, hogy egy modul azért van fent az oldalon, mert ugyan a közvetlen működéshez nincs rá szükség, viszont megkönnyíti a mindennapos munkálatokat. Ez a modul az utóbbiba tartozik, használd bátran és egy idő után rájössz, hogy mennyit segít. Amúgy vannak ilyen hasznos eszközök, pl. a Backup and Migrate (pedig sima SQL parancsokkal is lehet dumpot készíteni és visszatölteni) vagy a Drush. :)

0
0
vacati képe

Meggyőztél.

0
0
Balogh Zoltán képe

Nos, olyan, hogy végleges verzió egyszerűen NINCS. A fordítási adatbázis szinte percről percre változik, a drupal core fordítása ugyanúgy, mint bármely más contrib modulé.

0
0
vacati képe

Tényleg nem tudom hogyan tudtam nélküle élni :-)

Mellesleg, hogy miért nem végleges verzió az update... milyen hibái lehetnek?

Ugye az béta van közelebb a véglegeshez, nem az alfa?

HIBA: le akartam most tölteni a http://drupal.org/project/l10n_install modult, de nem az van benne, hanem a drupal 6.20-as core.

0
0
Pasqualle képe

It's not a Bug, it's a Feature!

0
0
vacati képe

I don't understand you.

0
0
nevergone képe

Amúgy meg ez az egész semmilyen formában nem kapcsolódik az eredeti kérdésfelvetéshez.

0
0
asrob képe

hogyha elolvasod mi van az állítólagos modul oldalára kiírva, akkor látod hogy az egy install profil ami milyen szerepet tölt be. Igen, van benne l10n_update modul, de benne van egy drupal core is. Mégpedig azért, hogy aki ezt letölti és fel szeretné telepíteni a drupalját akkor a telepítés elején tudjon választani sok-sok nyelv közül amelyre lefordították a drupalt. Tehát l10n_install nem egyenlő az l10n_update modullal. Egyébként ha van kérdésed valamelyikkel kapcsolatban akkor új kérdés új téma és szívesen válaszolunk rá ;)

0
0

--
Borsa Péter
https://asrob.eu