ures ablak a drupal inditasa utan; log file-ban semmi

Anonymous képe

w2K+Apche 2.0.53+PHP4.3.10+mysql4.1--> A rendszer működik.
> Drupal adatbázisát az AdminPHP-val felvettem, illetve kreáltam drupal felhasználót minden joggal.
> Mi az oka, hogy a http://localhost/drupal -ra (index.php-val is)
> egy üres oldalt kapok??
> Jól jönne egy kis segítség! Köszi: sz_a

H3ini képe

includes/conf.php -ben átírtál mindent?

(base url és egyebek)

0
0
Anonymous képe

A környezeti változók php-re mysql-re megadva.
A passwordot hozzáigazítottam a php-mysql vonalon.
Az általam bepakolt php file (drupal könyvtar alá), ami az általam létrehozott adatbázist nyitja meg, lefut simán.
Valami jogosultsági gubanc lehet, de se az apache, se a rendszer logfileaiban nincs semmi.
A conf php -ben mindent.
$base_url = "http://localhost/drupal";
$db_url = "mysql://drupal:[email protected]/drupal";
Így néz ki:
x:\php5
x:\mysql
x:\mysql\data
x:\apache
x:\jana\html ----> Ez a doc_root.
x:\jana\html\drupal
x:\jana\html\phpmysql ---->itt van az adminrész. Rendesen fut.

0
0
Anonymous képe

Valaki mondjon valami okasat legyen szíves!
Kitettem a telepítési útvonalakat is. (lásd fent:)

A drupal felhasználónak mindenhez van joga, de mégsem megy.

Előre is köszi. sz_a

0
0
Hojtsy Gábor képe

Nem tudjuk melyik Drupal verzió, pedig ez mondjuk alapvető lenne. Én az index.php-be tennék egy error_reporting(E_ALL); és egy ini_set('display_errors', TRUE); hívást, meg a set_error_handler() hívást kikommentezném (hogy a PHP alap hibakezelője menjen, és a képernyőn jöjjenek a hibaüzenetek). Aztán kiderül, mi a helyzet.

Különben az is lehet, hogy nem is oda mutat valamiért a docroot, és akkor az index.php-be tett egyszerű echo is megmutatja, hogy lefut-e...

0
0
Anonymous képe

drupal: 4.5.2
Ha beteszek egy másik index.php-t, ami mondjuk megnyit egy másik adatbázist, és beleír ezt-azt lefut simán.
http://localhost/drupal/index.php

Tehát az apach doc_rootként kezeli a könyvtárat, a php modulként működik, és mysgl is dolgozik.
Esetleg a drupálnak nem okoz-e gondot, hogy nem a root gyökerébe van bepakolva?
$base_url = "http://localhost/drupal";
Hol lehet még a drupalban base_dirt, vagy valami hasonlót állítani?

Köszi: sz_a

0
0
Hojtsy Gábor képe

Ajánlottam valamit fent, amit még nem próbáltál ki.

0
0
Anonymous képe

Kipróbáltam: Ezen a soron fennakad a conf-ban.

conf.php on line 37
0 * * * * wget -O - -q http://localhost/drupal/cron.php

0
0
chx képe

Legyél olyan kedves és mutasd meg nekem azt a leírást, amelyik azt mondta, hogy ezt a sort a conf.php-ba kell írni! A mókusok elé vetjük a szerzőjét. (amúgy a crontab-ba való)

0
0
Anonymous képe

A mókusoknak lehet, hogy beletörne a metszőfoga, vagy nem volna mibe harapni.
Kivettem ezt a sort, amit nem én tettem a confba. Utána a common.inc-ben jött vissza hibával.
Mérgemben újra kicsomagoltam az egészet, és láss csodát szó nélkül elindult.
Köszönöm a segítséget.
A my.ini-n kívül, nem árt az mysql más beállításaiba is bekukkantani.(path)
Ja, alapkódból valami beszúrhat ilyen sort a conf.php -ba, vagy valami hasonlót?
köszi:sz_a

0
0
Hojtsy Gábor képe

Nem módosítja semmi sem a conf.php-t, és más fájlokat sem, ha te nem teszed meg.

0
0
Anonymous képe

Még egyszer köszönet, de nem tudatosan került oda részemről, feltéve ha én tettem, lehet, hogy nyomtam egy CTRL+könyök kombinációt???
A drupál tetszik a maga egyszerűségével. Néhány óra után egész jól elboldogulok a meglévő dolgokkal. Egyetértek a weblabor cikkírójával, a váltást illetően. A másik rendszerhez képest nagyobb szabadságot hagy, ha jól látom.
Mielőtt teljesen elmélyednék a blokkok, modulok működésében, szeretnék kérdezni valamit:
Hogyan lehet a legegyszerűbben megoldani, hogy egy kész site kezdőoldala címoldalként jelenjen meg a modul_helyen(blokkok között címlapként)? (Tehát nem bepakolom egy textboxba.)
A blokkban elkészített menüpontnál, hogyan kell megadni pontosan a linket?
köszi: sz_a

0
0
Hojtsy Gábor képe

Mivel ez a kérdés nem kapcsolódik ide, itt ne is várj választ. Ha új témát szeretnél indítani, tudod hol teheted...

0
0
Anonymous képe

vettem
sz_a

0
0
chx képe

A Drupal nem valami gépikódú állat hogy önmódosító kódja legyen... eszébe sincs a conf.php-be túrni.

0
0
Anonymous képe

én is találkoztam már ezzel, de frissítettem php5-re, és azóta nem jött elő ez a hiba. egyébként amikor előjött, végül úgy tudtam, kiküszöbölni egy időre, hogy az url végére valami olyat írtam, ami 404-es hibát csinál, tehát pl a te esetedben egy ilyet írtam be, hogy "http://localhost/drupal/jadhbflabdvrew", és akkor bejött. szólt, hogy az oldal nem található, és akkor egy jódarabig nem jött elő ez a gond. érdekes mindenesetre...

norbee_usr

0
0