TinyMCE és FCKeditor probléma

Anonymous képe

Azért írok ennek új topicot, mert azt hiszem ez a hiba nincs megoldva, és konkrétan nincs is sehol megfogalmazva.

A drupal.org -on és itt is követem jó ideje az editorokkal kapcsolatos szálakat, de nem találok megoldást.

A drupal 5.0 alá tettem fel először az FCK-t és a Tiny-t is. Akkor mindkettő működött.

Aztán Drupal 5.1 alá is megpróbáltam, de ott egyik sem megy.

Tünet az FCKeditor-nál (utolsó verzió): modul betöltve, jogok meghatározva, de sehol sem jelenik meg a szerkesztő.

Tünet TinyMCE-nél (szintén legfrissebb verzió, a sites/all/modules könyvtárban, tinymce alkönyvtárban a 2.1.0. tinymce engine): Modul betöltve, jogok kiadva a használatra, adatbázis kézzel létrehozva, mert installkor nem megy magától (van hozzá patch, de kézzel egyszerűbb volt), aztán config: Create New Profile. Na itt megjelenik a beállító ablak, és szépen mindent be lehet állítani, de ha a Create profile gombra kattintok (submit) akkor az oldal nem található üzenetet kapom a browsertől.

Mi lehet a baj? Inkább a Tiny-t üzemelném be, de ha az FCK sikerül, most már azzal is beérném.

atilius képe

Nálam is ugyanez volt a probléma mind tinymce mind pedig a moxie esetében, azzal a különbséggel, hogy hiába hoztam létre kézzel az adattáblákat (a telepítő nem hozta létre őket automatikusan), a profilt nem tudtam létrehozni adatbázis hiba miatt. Nálam egyenként volt feltelepítve (majd összelőve) az apache, php, mysql hármas. Ledurtam az egészet és felraktam az xampplite-ot ami mindet összelőtte. Ezután már a telepítéskor símán létrejöttek az adattáblák, a profillal sem volt gond a moxie pedig hiba nélkül futott. Szóval szvsz valamilyen adatbázis hozzáférés/jogosultság hiba okozza a problémát. Kicsit körülményes ez a megoldás de működik. Nem tudom számít-e valamit, hogy mysql vagy mysqli, először az előbbivel majd később az utóbbival telepítettem a drupalt.

0
0
Anonymous képe

Az én helyzetem annyiban más, hogy a szerver nem az enyém, csak bérelek rajta tárhelyet és hozzáférést (php, mysql) ezért csak a kóddal és a táblákkal tudok babrálni.

0
0
atilius képe

Sajátgépen localhost alatt nem próbáltad? Ha ott menne akkor tuti, hogy a szerverrel van a baj.

0
0
Paal képe

Én éppen ma próbáltam ezt a verziójú TinyMCE-t telepíteni, sikerrel (localhost, XP, Apache). Tehát működik. Nálad lehet valami gond.

Üdv, Pali

0
0

--
Palócz Paal Pál, a drupal.hu admin csoportjának tagja
Ajánlott olvasmány: Eric Steven Raymond - Hogyan kérdezzünk okosan

Geva képe

drupal 5.1-es alá telepítettem a localhostra (saját gépre) az FCK modult hiba nélkül. Talán segíthetnek az alábbiak:
- Fontos feltétel a működéséhez, hogy a PHP 4.3.0-ás vagy újabb legyen.
- engedélyezni kell a böngészőt az editor config.php fájlban: $Config['Enabled'] = true ; amely eredetileg false;
- engedélyezni kell a drupal mappák használatát (én ezt választottam), egyébként létre kell hozni a files alá mappákat: "File", "Image", "Flash" és "Media";
- engedélyezni kell a szűrőknél bizonyos html tag-eket is;
Ezeket megtettétek? mind elérhetők a tárhelyen is...
Geva

0
0

Geva
----- Számítások

xzsolt képe

Sziasztok!

Most fogok hozzá egy teszt telepítésnek:

  • Az alap:
    • Fizetős web szolgáltató
    • Apache/1.3.37 (Unix)
    • PHP Version 5.2.1
    • MySQL 5.0.27
    • Drupal 5.1
  • A letöltés:
  • Kicsomagolás, FTP upload:
    • A modul: modules/tinymce
    • TinyMCE: modules/tinymce/tinymce
  • Adminisztráció> ...
    • modulok > Engedélyezett: TinyMCE 5.x-1.x-dev
    • Felhasználó kezelés > Hozzáférés szabályozás
    • Fontos: be legyen állítva mindkettő az authenticated user részére, mert különben nem jelenik meg. (access + administer tinymce)

    • Webhely beállítása ? TinyMCE > Add new TinyMCE profile
    • Itt is be kell jelölni a hozzáférést.

    (/modules helyett /sites/all/modules is tökéletes jó, tested)

    Ezeken éppen most mentem végig csont nélkül, tehát a telepítő működőképes adott körülmények között.

    Ha ez mégsem sikerül, akkor a szerveroldalon van a gond, küldj hibaüzeneteket.

    - Az installkor a tábla létrehozása milyen hibát adott?

    - Azt csak gyanítom, hogy kezdetben nem csak használatra kell a jog az authenticated felhasználónak, de utánna visszavonható.

    Mindenkinek sikeres telepítést!

0
0
Geva képe

Ezzel akkor most képeket és flash-t is tudsz beszúrni a szövegbe? próbáltad már?
Geva

0
0

Geva
----- Számítások

Paal képe

Én az img_assists-et használom. Van TinyMCE modul a csomagjában, amit a hozzá mellékelt leírás szerint lehet aktiválni. Ekkor egy új gombot lehet hozzáadni. Ez az image modul által felpakolt képeket tudja beszúrni TinyMCE segítségével. Az 5.x-es verzió mondjuk bugos volt, de a múlt hét óta már rendesen lehet használni.

Üdv, Pali

0
0

--
Palócz Paal Pál, a drupal.hu admin csoportjának tagja
Ajánlott olvasmány: Eric Steven Raymond - Hogyan kérdezzünk okosan

xzsolt képe

símán, a flash-t nem próbáltam, de képeket azt rendszeresen.

Létezik egy imce modul azzal rögtön feltöltés-böngészés-stb gomot is lehet odatenni, ez is korrektül működik.

0
0
Geva képe

Köszönöm az TinyMCE telepítést, leírásokat, végigcsináltam és némi kompromisszummal :-) megy az IMCE modullal a képek beszúrása.
Addig nem jelentek meg az szövegszerkesztő ikonok, amíg mint user 1 nem voltam besorolva a létrehozott profile felhasználói csoportjába :-)

A TinyMCE beállításánál van lehetőség a hu nyelvre beállítani, ám akkor a beállítás ellenére, nem jelenik meg a félkövér és dőlt formázó ikon, angolra állítva igen. Erre van valami megoldásotok? bár amíg magyar nyelvre le nem fordítom a modult...
(Magyarra állítva a nyelvet, a kép beszúrásánál a felugró ablakban nem fér el a tartalom, a jobb széle levágódik, így használhatatlan is, mivel itt lenne a kép beszúrásához a gomb)
Geva

0
0

Geva
----- Számítások

xzsolt képe

Hiányos a fordítás!!!

végigböngésztem, az ikonok eltünését és a abnormális elrendeződést a fordítási fájlból hiányzó szövegek okozzák/okozhatják, és nem utolső sorban nincs UTF-8 sem.

"elvileg" javítgattam rajta, ha kell valakinek oda tudom adni.

nem akartam publikálni mert nem találtam még tökéletesnek.

0
0
Geva képe

köszönettel venném
üdv
Geva

0
0

Geva
----- Számítások

randt képe

és valami readme , hogy hogyan lehet beszerelni...
Köszi.., és UTF8 -at ZH TW UTF8 a-t is be lehet állítani , megy majd vele vagy a sima hu legyen?

0
0
doeme képe

Kipróbáltam a te módszereddel is, ami kicsit más, mint amit a múltkor itt a fórumon ismertetett valaki. (akkor az egy másik drupal oldalon ment, csak a mostanin nem). És láss csodát. Felment és a create profile is műkszik, igaz a táblákat kézzel kellett csinálnom. A gond most már csak az, hogy nem jelenik meg a tinymce szerkesztő felülete, illetve ha a profile készítésénél üresen hagyom (a felsoroltak kivételével mindenhol), akkor megjelenik A TINYMCE PROFILE KÉSZÍTŐ MENÜJÉNEK SZÖVEGMEZŐJÉNÉL. Bármit állítok, máshol nem tudom előcsalni. Mi lehet a baj?

0
0
xzsolt képe

Erre gondoltál?

Show tinymce on specific pages:

o Csak a felsorolt oldalakon jelenjen meg.

node/*
user/*
comment/*

Ezzel kapcsolatban jut eszebe egy dolog:
A i18n használata esetén az útvonalban megjelenik a nyelv kódja, ami egy kicsit megtréfálja a tinymce használókat, mert eltünteti (vagy nem jeleníti meg, ahogy tetszik). Ez azért történik, mert a módosított útvonal nem illeszkedik a feltételre, ezért ezt is korrigálni kell:

*/node/*
*/user/*
*/comment/*

Ez természetesn minden más útvonalbabráló modulnál fennállhat!

Egy másik dolog ami még megakadályozza megjelenést a jogosultság beállításánál. Itt ahhogy már írtam az authenticated user-nek is kell minden jog, mert az alap nem elég.

0
0
doeme képe

OKULÁSUL MINDENKINEK!

ZSOLT TELEPÍTÉSI LEÍRÁSÁVAL MÉG AZ ÉN GYÖSZÖS DRUPALOM IS KIRAKTA A TINYMCE-T.
DE!!!!!UTOLSÓ ELKESEREDÉSEMBEN ÁTRAKTAM A SMINKEMET BLUEMARINE-BE ÉS MEGJELENT....AZ ALAPSMINKEM, EGY BLUEMARINBŐL ÁTALAKÍTOTT SMINK, AZ VOLT FENT A 4.7.2-ES DRUPALON IS, ÉS AKKOR NEM NYÍRTA KIA TINYMCE-T. SZÓVAL HA FELPISZKÁLT SMINKETEK VAN ÉS NEM MEGYA TINY, AKKOR TEGYÉTEK ÁT MÁSIK SMINKBE...

KÖSZÖNÖM MINDENKINEK

0
0
pla képe

Ha már a felhasználói jogok jöttek szóba... hogyan adható meg eltérő jogosultság?
Azaz mondjuk a regisztrált felhasználó ne legyen jogosult kép beszúrásra, sem egyéb nyalánkságra, csak az alap szövegformázásokra, míg egy szerkesztői státuszú egyén igen?
Most minden user kizárólag a regisztrált felhasználó szintjének megfelelő szerkesztői felületet kapja, hiába vannak meg a felhasználói csoportok, bennük a tagokkal, illetve hiába a beállítási profilok. Mintha nem rendelné egymáshoz őket. (Korábban mintha már működött volna a dolog, de nem emlékszem hogyan sikerült egy fél napos eszeveszett kattintgatással előidézni.)
472-t használok, localhostos teszteléssel, illetve az extrán az ottani korlátozásokkal futtatom ugyanezt a verziót. Természetesen ha az extra hülyeségei miatt nem megy, az egy dolog, de hogy localhoston sem, az zavaró, mert így nem látom értelmét annak, hogy esetleg befizessek rendes hostra.

0
0
randt képe

A modul előjött, és profilt is beállítottam, de tartalom beküldésekor nem jelenik meg a szerkesztőfelület.
5let?
Üdv.
Javat telepítettem, xzsolt leírása alapján feltettem mindent csak frissebb verzióban, és 5.5 re.

0
0
randt képe

mit lehetne tenni hogy ne takarja ki a menüket a jobb oldlon?
Valamint a magyar fordítás jól jönne mert a kép feltöltésnél nekem sem jelenik meg a kezelő gombok amik alúl vannak.

0
0
pp képe

Milyen sminknél jön elő a probléma?
Megoldási javaslatok:

1. admininsztráláshoz válassz másik sminket
2. firefox firebug megkeres iframe id-je, ennek szélességét beállít.
3. firefox firebug megkeres befoglaló div -> overflow:auto;

pp
(ja és már nem is szólok, hogy indíts új témát és ne ide piszkíts)

0
0
airzsolt képe

Nem is tudom, hogy a számtalan tinymce fórum közül melyikbe írjam, de mivel ez van épp elöl, ide írom.

Van itt egy hír: Interest in TinyMCE Lesson?
eszerint egy-két héten belül stabilizálódik a tinymce helyzet, illetve 18-án, ha lesz elég érdeklődő, a modul egyik fejlesztője egy bemutatót fog tartani, ami többek közt a telepítés problémáiról is fog szólni.

0
0
Anonymous képe

Nekem persze továbbra sem működik a TinyMCE. Lehet-e az gond, hogy a MySQL verzio 3.x.x?

0
0
xzsolt képe

Valami hibajelzésnek kellene lenni, küldj be valamit, mert így nem tudunk segíteni.

De mindenképpen ellenőrizd le hogy mindent jól csinálsz, és minden verzió megfelelő, és megfelelő helyen van. (pl. A tinymce két csomagja)

0
0
Anonymous képe

Szerintem mindent jól csinálok. lépésről-lépésre mindent betartok. Hibaüzenet nincs (akkor könnyebb lenne) Egyszerűen a Create Profile gombra kattintásnál az oldal nem található jön elő az explorerből (mégcsak nem is a drupalos). Nem is nézi meg, hogy a kötelező mezőket kitöltöttem-e vagy ilyesmi.

0
0
xzsolt képe

Ha jól tévedek ez a jelenség a tinymce két csomagjának hibás elhelyezéséből adódik (úgy emléxem, valamikor én is elszurtam és ilyesmit tapasztalatam) olvasd át a doksit, ha nem világos a fentiek alapján.

Esetleg küldj be egy könyvtárlistát (v. képet) a modules/tinymce -ból kiindulva.

0
0
Anonymous képe

modules\tinymce
modules\tinymce\po
modules\tinymce\themes
modules\tinymce\tinymce\docs
modules\tinymce\tinymce\jscripts
modules\tinymce\tinymce\jscripts\tiny_mce
modules\tinymce\tinymce\jscripts\tiny_mce\plugins
modules\tinymce\tinymce\jscripts\tiny_mce\langs
modules\tinymce\tinymce\jscripts\tiny_mce\themes
modules\tinymce\tinymce\jscripts\tiny_mce\utils
modules\tinymce\tinymce\examples
modules\tinymce\tinymce\examples\templates

további mélységekben nem írom le, ott még van sok könyvtár, főleg a plugin-oknál

0
0
oky képe

Szóval. Egy dolgot mindenki kihagy, akinek nem megy: először a 'Hozzáférés szabályozás' alatt engedni kell legealább 1 csoportnak az 'access tinymce' jogot.
Utána lehet profájlt állítani a TinyMCE beállításánál, és legalább egy csoportot ki kell pipálni a 'Basic' részben. Ezután az adott csoport tagjai tudják használni az editort.

0
0
xzsolt képe

ééééén figyelmeztettem mindenkit (2x is) lásd fentebb....

:-)

0
0
kisgonosz képe

már szégyellem de nem találom hol kell beállítani ezeket a jogosultságokat.
goni..

0
0

goni..

randt képe

akiknek engedélyeztem, a felhasználó hozzáférésben, a sima regisztrált felhasználónak nem akartam, csak azoknak akiket regisztráció után egy szinttel feljebb sorolok. Megjelent a kezelőfelület miután megengedtem nem csak az általam létesített csoportoknak, hanem az authenticated user nek is.

0
0
Anonymous képe

Ezt a hibaüzit írja ki miután ftp-n feltöltöm az editor mappáját a /penzteremtes/sites/all/modules mappába. "The FCKeditor component is not installed correctly. Please go to the FCKeditor homepage to download the latest version. After that you must extract the files to /penzteremtes/sites/all/modules/fckeditor/fckeditor/ and make sure that the directory /penzteremtes/sites/all/modules/fckeditor/fckeditor/editor and the file /penzteremtes/sites/all/modules/fckeditor/fckeditor/fckeditor.js exist. Refer to the readme.txt for more information."

Értem amit hiányol, de ha egyszer nincs ott az a fránya fckeditor.js fájl, akkor honnan szedjem elő??

0
0
pp képe

Az FCKeditor js editor egy a Drupaltól független fejlesztés. Az FCKeditor modul ezt a külső fejlesztést integrálja a rendszeredbe, de maga a modul nem tartalmazza azt, neked külön le kell tölteni az FCKeditor honlapjáról. (de ezt minek is mondom, hisz ezt Te is el tudod olvasni, de remélem most már érted is ;)) :

Please go to the FCKeditor homepage to download the latest version

pp

0
0
ngergihun képe

Nekem is az a bajom az fckeditorral, hogy nem jelenik meg sehol, pedig be van töltve jogokat megadtam stb...
Én bérelt tárhelyen vagyok linuxos szerveren, pgsql adatbázissal, de nem műkszik. Mi lehet a bajj, mit tegyek???

0
0
nevergone képe

Először is indíts új témát a kérdésednek légyszi', mivel ez a fórumtéma már eléggé "lejárt" itt.
Aztán ebben az új fórumtémában adj meg minden hasznos adatot, ami segíthet a hiba felderítésében: Az általad használt Drupal, FCKEditor, PHP, és egyéb modulok verziószámát, illetve azt, hogy mivel próbálkoztál eddig, hogyan telepítetted, stb.

0
0