PHP verzió váltás

Justice képe

Sziasztok!
jelenleg a tárhelyemen php 5.6 alatt futnak drupal honlapok. Ha váltok mondjuk php7.2 vagy 7.3-as verzióra lehet valami gikszer a futtatással? Szükség lehet bármilyen beállításra előzőleg?

Drupal verzió: 
nevergone képe

Szia!

Ezt így nem lehet megmondani, ez a használt moduloktól függ. Azt javaslom, hogy valamilyen helyi környezetben teszteld le előtte.

0
0
Justice képe

köszönöm:)

0
0
Drufan képe

Nagyon is lehet. Én bele is futottam.
A localhost-on 7.0-s PHP-val csináltam az oldalt, amikor feltöltöttem a tárhelyre, ott volt 7.3-as, beállítottam azt, ha már van és beszart az oldal. Kiderült, hogy az egyik modul nem megy rajta jól. Elkezdtem visszalépegetni, és 7.2-nél már nem volt gond, de mivel a localon továbbra is 7.0 van, inkább visszaléptem addig. Majd ott is frissítek és többet nem teszek ilyet, hogy nem ugyanolyan rendszeren fejlesztek és tesztelek.

0
0
asrob képe

Azt ugye tudod, hogy a PHP 7.0.x EOL már majd 1 éve?
Lásd: https://www.php.net/supported-versions.php

Érdemes a fejlesztői és az éles környezetet szinkronba hozni, támogatott verziókat használni és figyelemmel kísérni, hogy mind a core, mind a használt contrib modulok megfelelően támogatják-e az adott PHP verziót pl. Ha nem akkor jelenteni és/vagy patch-et beküldeni.

2
0

--
Borsa Péter
https://asrob.eu

Drufan képe

Fel akarom vinni 7.3-ra, de a Wamp server-t nem lehet frissíteni, újra kell telepíteni és még nem volt hozzá kedvem, időm. És ilyenkor sok minden elkúródik, szóval tervben van.

A Drupal modulnál nem jelezte a fejlesztője, hogy gond lenne 7.3-nál, szóval nem tudom ez hol deríthető ki anélkül, hogy egy összeomlás mutatná meg. Ez amúgy egy Adatvédelmi nyilatkozat, Felhasználói szerződés elfogadós modul.

0
0
HF leon képe

Felesleges az egészet újrarakni. Töltsd le a php-t és tedd fel kézzel. a legtöbb beállítás azonos a két verzió közt. Lehet egyszerre több php-d is. Mindig azt beállítva aktívnak, amelyiken az adott tárhely van, ahol az oldal fut.

0
0
Drufan képe

A mySQL-el ezt meg mertem csinálni régebben, de PHP-val most nem, mert a mySQL-nél le volt írva, hogy hol, melyik file-ban mit kell babrálni azon kívül, hogy odateszem az újat.

0
0