HTTP500 error telepítésnél

taki47 képe

Sziasztok!

Most szeretnék ismerkedni a Drupal-al, így letöltöttem innen a legújabb verziót, majd amikor telepíteni akartam egy szép nagy 500-as ERROR fogadott :-)

Apache/PHP/MySQL-em van, nem XAMPP-al telepítettem. Az apache error log-ja a következőt mondja erre:

[Fri Apr 20 17:01:19 2018] [error] [client 127.0.0.1] PHP Parse error:  syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or '(' in D:\\sajat\\web\\drupal\\core\\install.php on line 8

Feltételezem az nem jó ötlet, hogy én nyúlok bele a drupal forráskódjába, és írom át, mert valószínűleg több oldalon is elő fog ez fordulni.

Mi az a beállítás, ami miatt ezt nem értelmezi?

Nagyon köszönök minden segítséget :-)

Taxonomy upgrade extras: 
Drupal verzió: 
nevergone képe

Szia!

Milyen Drupal verziót és milyen PHP verziót használsz? Nem módosítottál semmit a fájlokon?

0
0
taki47 képe

Szia!

Drupal: 8.5.2, most töltöttem le innen :-)
PHP: 5.2
Apache: 2.2

Mit értesz az alatt, hogy nem módosítottam a fájlokon? Drupalon belül nem, csak kitömörítettem a webszerver könyvtárába.

0
0
nevergone képe

Szia!

Hagyd el a PHP 5.2-őt és 7.2.x-ig meg se állj: https://www.drupal.org/docs/8/system-requirements/drupal-8-php-requirements
A PHP 5.2.x a Drupal 6-nak volt megfelelő sok-sok évvel ezelőtt.

1
0
asrob képe

PHP követelmények: https://www.drupal.org/docs/8/system-requirements/drupal-8-php-requirements

Szóval PHP 5.2.x-el nem is fog menni.

1
0

--
Borsa Péter
https://asrob.eu

HF leon képe

A drupal 8 rendszerkövetelményei php terén minimum 5.5.9, vagy újabb, de a normális működéshez a 7.1, vagy 7.2 az ajánlott. A legtöbb szolgáltatónál ezek elérhetők.

(Az 5.6.x-es verziók támogatottsága hamarosan kivezetésre kerül.)

Az 5.6.x és 7.0.x php verziók életciklusa is lejár 2019-ben.

https://www.drupal.org/docs/8/system-requirements/drupal-8-php-requirements

Otthoni használatra, tesztelésre használd a Wamp server-t, vagy a Laragon-t. Mindegyik tökéletesen megfelelő a laragon jobb, de kezdésnek bonyolultabbnak tűnhet.

Xampp-ból is van modernebb verzió:

https://www.apachefriends.org/hu/download.html

1
0