A google robotok egy nem letezo konyvtarat keresnek?

zoliky képe

A drupal alapu weblapom korubelul ket honapja a kovetkezo cimen volt elerheto: www.weblap.hu/drupal. Jelenleg a "drupal" folder mar nem letezik az FTP-n.
A drupal lap a gyoker konyvtarban van, szoval eleg csak a kovetkezo cimet begepelni: www.weblap.hu

A gond az, hogy a log uzenetekben nagyon sok lekerest kapok es mind a /drupal foldert probaljak megnyitni annak elenere, hogy a www.weblap.hu/drupal mar nem letezik. Ez igy megy sok ideje, es kezd idegesito lenni. A google azokat az oldalakat kene megtartsa amelyek leteznek :)

Meg lehet ezt valahogy oldani, hogy ne keresek a nem letezo foldert ?

Koszonom!

Fórum: 
Illyés Edith képe

Hojtsy Gábor képe

Gondolom várja, hogy hátha visszajön, mert előtte hagytad, hogy ott leindexelje. A hivatalos érteítés arról, hogy biztosan nem lesz már többet ott az a tartalom, ha beállítod, hogy "410 Gone" választ ad a szerver, akkor biztos lehet benne a Google is, hogy nem lesz már ott többet az, ami korábban volt. (Ennél kicsit optimálisabb, ha inkább "301 Moved Permanently"-t használsz, hogy megmutasd, hova költözött a tartalom).

0
0
zoliky képe

1.A kovetkez kod eleg lesz neki ? :

header("HTTP/1.1 301 Moved Permanently");
header("Location: http://ujoldal.hu");

2. Letrehozom ujbol a /drupal konyvtarat es oda rakom a kodot ?

0
0
andrew képe

nem, mert egyrészről ez nem fog működni pl erre:
/drupal/irasok/123

másrészről gondolom az útvonal elérések maradtak a régiben, szóval nem mindent az új gyökérbe kellene küldeni, hanem az eredeti útvonalat megtartva csak a "/drupal/" részt kivéve kellne a 301

tehát pl.:

oldalad.hu/drupal/irasok/123
301 to: oldalad.hu/irasok/123

0
0
zoliky képe

nem, mert egyrészről ez nem fog működni pl erre:
/drupal/irasok/123

Igazad van, koszonom!

Oszinten mit tudnek hasznalni, mod_rewrite? Esetleg tudnal adni egy peldat (elnezest ha sokat kerek).

0
0
andrew képe

a documentroot -ban lévő .htaccess rewrite szabályai között az elsőnek tedd be:

RewriteRule ^drupal/(.*) /$1 [L,R=301] 

ja és nem tudtam most tesztelni, úgyhogy szólj h miként megy! :)

0
0
zoliky képe

koszonom!
most keresgelem a .htaccess fajlot, mert nem latom az FTP szerveren. Az FTP kliensem Total Commander.
Nagy a gyanum, hogy a hosting ceg eltunteti, mert a merevlemezemen megtalalom.

0
0
andrew képe

rejtett file -ok megjelenítése opciót kattintsd be (ha jól emlékszem még régin win -es időkből :) ), utána látni fogod

0
0
zoliky képe

Ide raktam be a rewrite sort, a legalso:

# Various rewrite rules.

RewriteEngine on

# If your site can be accessed both with and without the prefix www. you
# can use one of the following settings to force user to use only one option:
#
# If you want the site to be accessed WITH the www. only, adapt and
# uncomment the following:
# RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
# RewriteRule .* http://www.example.com/ [L,R=301]
#
# If you want the site to be accessed only WITHOUT the www. prefix, adapt
# and uncomment the following:
# RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
# RewriteRule .* http://example.com/ [L,R=301]

# Modify the RewriteBase if you are using Drupal in a subdirectory and
# the rewrite rules are not working properly.
#RewriteBase /drupal

# Rewrite old-style URLs of the form 'node.php?id=x'.
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{QUERY_STRING} ^id=([^&]+)$
#RewriteRule node.php index.php?q=node/view/%1 [L]

# Rewrite old-style URLs of the form 'module.php?mod=x'.
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
#RewriteRule module.php index.php?q=%1 [L]

# Rewrite current-style URLs of the form 'index.php?q=x'.
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

# rewrite old drupal page
RewriteRule ^drupal/(.*) /$1 [L,R=301]

Kitoroltem a /drupal foldert az FTP cimrol, most megprobaltam elerni az oldalt:
http://weblap.hu/drupal/node/242 de nem kuldi at a regi cimre.

0
0
andrew képe

aszondtam, h első rule -nak!!!

0
0
zoliky képe

Ok, koszi most mukodik. Nem gondoltam, hogy szamit a sorrend.

0
0
andrew képe

ok, örülök, h megy...

nem hiába írtam, h elsőnek tedd be. a rule -ok feldolgozása sorról-sorra történik és az első illeszkedő szabály "nyer", így ahogy utolsónak tetted be az történt, h előbb feldolgozásra került a drupal saját rövid url -es beállítása és nem jutott el a tiedig.

0
0
andrew képe

szerintem mod_rewrite lesz a barátod.

a www.weblap.hu/drupal/* oldalra kellne 301 -es kóddal (moved permanently) válaszolva hivatkozni az új helyre...

0
0