frissítés utáni hibaüzenetek

Krisztian019 képe

Sziasztok!

Drupal 7.26-ot használok. volt néhány modul ami frissítésre szorult, így frissítettem is őket. De frissítés után ezek a hibaüzenetek jelentek meg piros háttérrel:

Warning: class_implements() [function.class-implements]: Class TranslationsStreamWrapper does not exist and could not be loaded file_get_stream_wrappers() függvényben (/home/domain/public_html/includes/file.inc 136 sor).

Warning: in_array() expects parameter 2 to be array, boolean given file_get_stream_wrappers() függvényben (/home/domain/public_html/includes/file.inc 136 sor).

valamint az állapot jelentéseknél 3 dolgot jelöl pirossal ezek a következők:

Adatbázis frissítések Elavult
Néhány modul adatbázis séma frissítéseket igényel. Az adatbázis frissítést azonnal le kell futtatni.

Hiba
Public files directory Not fully protected
See http://drupal.org/SA-CORE-2013-003 for information about the recommended .htaccess file which should be added to the sites/default/files directory to help protect against arbitrary code execution.

Temporary files directory Not fully protected
See http://drupal.org/SA-CORE-2013-003 for information about the recommended .htaccess file which should be added to the /tmp directory to help protect against arbitrary code execution.

Ha az adatbázist megpróbálom frissíteniezek a hibaüzentek jönnek

Unresolved dependency libraries (Missing)
Patterns requires this module.

Error
Unresolved dependency libraries (Missing)
PHP Parser requires this module.

Még kezdő vagyok sok mindent nem tudok, de túl sok hiba ez nekem egyszerre, nem tudom merre induljak el, vagy hogy a hibák összefüggenek e egymással, vagy teljesen külön kell őket kezelni? Ha valaki tud mondani valami okosat merre induljak, azt nagyon megköszönném.

Fórum: 
csakiistvan képe

Ezt a modult hianyolja: https://drupal.org/project/libraries

0
0

-
Features, drush, git... ne nélkülözd őket

szantog képe

Hiba
Public files directory Not fully protected
See http://drupal.org/SA-CORE-2013-003 for information about the recommended .htaccess file which should be added to the sites/default/files directory to help protect against arbitrary code execution.

Temporary files directory Not fully protected
See http://drupal.org/SA-CORE-2013-003 for information about the recommended .htaccess file which should be added to the /tmp directory to help protect against arbitrary code execution.

Ehhez ajánlom magamat: http://szantogabor.com/hirek/htaccess-security-fix-a-hozzam-hasonlo-lust...
Nézd meg a kommenteket is, lehet, nem kell hozzá letöltened, amiről írtam.

Adatbázis frissítések Elavult
Néhány modul adatbázis séma frissítéseket igényel. Az adatbázis frissítést azonnal le kell futtatni.

Menjél ide: http://oldalam/update.php, és kövesd az ott leírtakat.

Warning: class_implements() [function.class-implements]: Class TranslationsStreamWrapper does not exist and could not be loaded file_get_stream_wrappers() függvényben (/home/domain/public_html/includes/file.inc 136 sor).

Warning: in_array() expects parameter 2 to be array, boolean given file_get_stream_wrappers() függvényben (/home/domain/public_html/includes/file.inc 136 sor)."

Ez a kettő összefügg, egy cache-törlés lehet megoldja, ez elvileg az update.php futtatása után magától megtörténik.
Ha így sem jó, akkor B terv: https://drupal.org/project/registry_rebuild

Ha a registry_rebuild sem oldja meg, akkor ott valamelyik modul csúnya dolgot csinált, és azt sajna nem lesz egyszerű megtalálni.

0
0

----
Rájöttem, miért kérdezek olyan ritkán a drupal.hu-n. Amíg szedem össze az infokat a kérdéshez, mindig rájövök a megoldásra.

Phoere képe

Warning: class_implements() [function.class-implements]: Class TranslationsStreamWrapper does not exist and could not be loaded file_get_stream_wrappers() függvényben (/home/domain/public_html/includes/file.inc 136 sor).

A Localization Update (l10n_update) modul frissítése okozza a hibát. Hogy pontosan miért, nem tudom, de annak eltávolítása után megszűnt.

1
0

Csökönyi Ferenc

Phoere képe

Leszedtem az rc2 verziót és visszatettem az rc1-et, így megszűnt a hibaüzenet.

0
0

Csökönyi Ferenc

Krisztian019 képe

Köszönöm! Valóban ez volt a probléma, én is töröltem és eltűnt a hiba.

0
0
Phoere képe

Az április 12-ei frissítésben a megjegyzések szerint javította a hibát a modul készítője.

0
0

Csökönyi Ferenc