Frissítés D8.5.3-ról - update.php hiba

Joee képe

Próbáltam frissíteni a D8-at. Amikor az update.php-t futtatom, ezt a hibaüzenetet kapom:
"The website encountered an unexpected error. Please try again later."
Az állapotjelentésnél az új verziót írja a Drupal. Látszólag rendben lenne minden, kivéve néhány dolgot. A karbantartási mód oldalra kattintva ez a hibaüzenet jön elő: "A webhelyen nem várt hiba történt. Később érdemes újra megpróbálni."
Ugyanez a hibaüzenet jön elő a "Felhasználók" és a "Bővítés" menüpontra kattintva.
Másik jelenség, ha a ".../index.php/admin/reports/updates/update" (Elérhető frissítések) helyen kijelölöm a "AddToAny Share Buttons" modult frissítésre és a "Frissítések letöltése" gombra majd a "Folytatás" gombra kattintok akkor ide dob:
".../index.php/core/authorize.php?batch=1&id=1637&op=start"
Ez talán azonosításkérő oldal lenne, de a főoldalra dob és közben be vagyok jelentkezve Frissíteni a 8.5.3 verzióról próbáltam a 8.5.5-re, de a leírt hibajelenség jött elő. Gondoltam, hogy megpróbálom először a frissítést a 8.5.4-re, de ott is ugyanez a jelenség. Tudja valaki mitől lehet ez?

Drupal verzió: 
dongodani képe

A D8-at nem érdemes frissíteni, legalábbis egyelőre. Nekem eddig még mindig elxarta az addigi rendszereimet. Elég rendesen... Ez van, a D8-al megszűnt a D7-nél megszokott gondtalan frissítgetés, nem kiforrott még ez a része...

0
-2
Balu Ertl képe

"Próbáltam frissíteni a D8-at."

Hogyan, melyik módszerrel próbáltad? Composerrel, Gittel, vagy csak simán fájlrendszerben felülírással?

"The website encountered an unexpected error. Please try again later."
"A webhelyen nem várt hiba történt. Később érdemes újra megpróbálni."

Ez az ún. exception hibaüzenete a Drupalnak, ami statikus, hiba eredetétől függetlenül mindig ugyanaz. Elég csak annyit írnod, hogy exceptiont dob.

Mit látsz a Hibajelentések között? El tudsz oda navigálni, engedi megnyitni? Ha igen, mi az utolsó bejegyzés, mikor a hibát tapasztalod?

Ha nem tudod megnyitni, akkor mit látsz a PHP logban?

0
0
Joee képe

A frissítést a \core\UPDATE.txt alapján próbáltam. Töröltem a tárhelyről a core és vendor mappákat valamint minden fájlt a főkönyvtárban. Letöltöttem a tárhelyről az állományt (drupal-8.5.5) ebből felmásoltam a tárhelyre a core és vendor mappákat és a főkönyvtár fájljait. A ../sites/default/settings.php fájlban a "$settings['update_free_access'] = FALSE;" értéket true-ra változtattam majd futtattam a update.php fájlt. Erre jön a fenti hibaüzenet.
A naplóüzeneteknél rászűrtem a hibákra és ez van többször:
"Drupal\Component\Plugin\Exception\PluginNotFoundException típus: The "migrate_example_advanced_position" plugin does not exist. üzenet Drupal\Core\Plugin\DefaultPluginManager->doGetDefinition() függvényben (.../core/lib/Drupal/Component/Plugin/Discovery/DiscoveryTrait.php fájl 52. sorában)."
Van még ez:
"A FieldStorageConfigInterface::getBundles() egy nem létező konfigurációs entitástípus nevével tért vissza. (Mező neve: comment_body, mezőköteg: comment_node_migrate_example_beer.)"
Ez is van:
"Drupal\Component\Plugin\Exception\PluginNotFoundException: The "entity:poll" plugin does not exist. üzenet Drupal\Core\Plugin\DefaultPluginManager->doGetDefinition() függvényben (.../core/lib/Drupal/Component/Plugin/Discovery/DiscoveryTrait.php 52. sorában) #0 .../core/lib/Drupal/Component/Plugin/Discovery/DiscoveryCachedTrait.php(25): Drupal\Core\Plugin\DefaultPluginManager->doGetDefinition(Array, 'entity:poll', true) #1
.../core/lib/Drupal/Core/Plugin/Factory/ContainerFactory.php(16): Drupal\Core\Plugin\DefaultPluginManager->getDefinition('entity:poll') #2 .../core/lib/Drupal/Component/Plugin/PluginManagerBase.php(84): Drupal\Core\Plugin\Factory\ContainerFactory->createInstance('entity:poll', Array) #3 .../newhirek/core/modules/views/src/Plugin/views/display/DisplayPluginBase.php(817): Drupal\Component\Plugin\PluginManagerBase->createInstance('entity:poll') #4 .../core/modules/views/src/Plugin/views/style/StylePluginBase.php(122): Drupal\views\Plugin\views\display\DisplayPluginBase->getPlugin('row') #5 .../core/modules/views/src/Plugin/views/display/DisplayPluginBase.php(820): Drupal\views\Plugin\views\style\StylePluginBase->init(Object(Drupal\views\ViewExecutable), Object(Drupal\views\Plugin\views\display\Page), Array) #6 .../core/modules/views/src/ViewExecutable.php(882): Drupal\views\Plugin\views\display\DisplayPluginBase->getPlugin('style') #7 .../core/modules/views/src/ViewExecutable.php(1842): Drupal\views\ViewExecutable->initStyle() #8 .../core/modules/views/src/Plugin/views/display/PathPluginBase.php(132): Drupal\views\ViewExecutable->getTitle() #9 .../core/modules/views/src/Plugin/views/display/Page.php(91): Drupal\views\Plugin\views\display\PathPluginBase->getRoute('poll_list', 'page_1') #10
.../core/modules/views/src/Plugin/views/display/PathPluginBase.php(220): Drupal\views\Plugin\views\display\Page->getRoute('poll_list', 'page_1') #11 .../core/modules/views/src/EventSubscriber/RouteSubscriber.php(120): Drupal\views\Plugin\views\display\PathPluginBase->collectRoutes(Object(Symfony\Component\Routing\RouteCollection)) #12 [internal function]: Drupal\views\EventSubscriber\RouteSubscriber->routes() #13 .../core/lib/Drupal/Core/Routing/RouteBuilder.php(146): call_user_func(Array) #14 .../core/lib/Drupal/Core/ProxyClass/Routing/RouteBuilder.php(83): Drupal\Core\Routing\RouteBuilder->rebuild() #15 .../core/includes/common.inc(1157): Drupal\Core\ProxyClass\Routing\RouteBuilder->rebuild() #16 .../core/modules/system/src/Controller/DbUpdateController.php(350): drupal_flush_all_caches() #17 .../newhirek/core/modules/system/src/Controller/DbUpdateController.php(164): Drupal\system\Controller\DbUpdateController->selection(Object(Symfony\Component\HttpFoundation\Request)) #18 [internal function]: Drupal\system\Controller\DbUpdateController->handle('selection', Object(Symfony\Component\HttpFoundation\Request)) #19 .../core/lib/Drupal/Core/Update/UpdateKernel.php(110): call_user_func_array(Array, Array) #20 .../core/lib/Drupal/Core/Update/UpdateKernel.php(73): Drupal\Core\Update\UpdateKernel->handleRaw(Object(Symfony\Component\HttpFoundation\Request)) #21 .../update.php(28): Drupal\Core\Update\UpdateKernel->handle(Object(Symfony\Component\HttpFoundation\Request)) #22 {main}."

0
0
dongodani képe

Én azért megnézném, hogy abban a törölt vendor mappában nem voltak-e olyan utólag telepített pluginok, ami a frissítettből hiányoznak. Composeres modul telepítéskor ide kerülnek a külső pluginok. A felmásolt mappák és fájlok jogosultságait is összevetném a korábbi verzióval. Nem megfelelő php verzió is okozhat galibát...
Ha csak két nyers alaprendszert frissítesz az említett verziókból, akkor is elő jön ez a a hibalista? Egy utólag telepített modul is lehet ludas...

0
0
Joee képe

A frissítés megtörtént, de nem tudom mennyire elfogadható?
A leírás szerint mindig a fenti hibaüzenet jött. Majd ú gy csináltam, hogy a drupal org-ról letöltött drupal-8.5.5.zip állományt kitömörítettem és egyszerűen bemásoltam teljes egészében a szerver Drupal mappájába felülírással. Utána futtattam az update.php-t. Erre kiírta, hogy "Nincs függőben lévő frissítés."
Ellenőriztem a rendszer verziószámát és a helyes 8.5.5 verziószámot írja.
A korábbi a mellékelt leírás szerinti frissítéskor az update.php futtatása után mindig csinált valamit az adatbázisban és akkor jött létre a hiba.
Most azt szeretném tőletek megtudni, hogy jó-e így ez a frissítés?

0
0