csatolmány letöltés nem megy

Anonymous képe

Sziasztok!

Miért lehet az, hogy a hozzászólásokhoz becsatolt állományokat gond nélkül feltölti a drupal, viszont a hozzászólás megtekintésekor hiába kattintok az attachment-re, letölteni már nem lehet. A hibaüzi a logban: Page not found.
A feltöltött fájl ott figyel a /files könyvtárban, a .htaccess-t töröltem, minden jogosultságot rátettem a fájlra is meg a /files könyvtárra is.
Próbáltam játszani a public/private kapcsolóval a csatolmányok opcióinál, de az se segített.

Segítség...

Illyés Edith képe

Ha az egeret az attachment link fölé viszed, milyen útvonalat ír a böngésző állapotsorába? (Egyes moduloknál előfordul, hogy a /files könyvtárban keresnek, pedig a /system/files-ban kellene.)

Az adatbázis files táblájában milyen útvonal szerepel?

0
0
Anonymous képe

Ha az egeret a link fölé viszem, ezt írja:
http://gandalf.akarmi.hu/drupal/?q=//gandalf.akarmi.hu/drupal/%3Fq%3Dsys...

Ott a végén, hogy sytem/files...

Az files táblában ez van:
| 2 | 18 | xyz.zip | files/xyz.zip | application/zip | 51296 |

0
0
Illyés Edith képe

... de nem furcsa egy kicsit az eleje?

http://gandalf.akarmi.hu/drupal/?q=//gandalf.akarmi.hu/drupal/%3Fq%3D

Valószínűleg a 'beállítások -> Fájlrendszer beállítások' űrlapon adtad meg rosszul az elérési utat. Csak a Drupal installáció gyökerétől (ahol az index.php fájl van) számított útvonalat kell megadni, pl. sites/default/files.

0
0
Anonymous képe

Tudom, hogy csak relatív útvonalat kell megadni a drupal gyökérhez viszonyítva. Mivel én itt (drupal főkönyvtárában) hoztam létre a files könyvtárat, ezért csak annyit írtam be, hogy "files". Ezt így el is fogadta, és jónak is kell lennie, hiszen a hozzászóláshoz csatolt fájl szépen oda is másolódott a helyére.
Ha azt próbálom megadni, hogy "/files" akkor hibát jelez és nem fogadja el az útvonalat.
A linkben van a hiba, de nem tudok rájönni, hogy mi okozza az elérési útvonal öszekuszálódását.

0
0
Illyés Edith képe

A settings.php-ben mit adtál meg $base_url-nek?

0
0
Anonymous képe

A $base_url volt rosszul beállítva. Lemaradt róla a "http:". Így már működik minden rendesen.

Köszi a segítséget!

0
0
grof képe

Sziasztok!

Én is ezzel szívok. De ha a .htaccess fájlt törlöm a files könyvtárból, akkor szépen működik. Ha nem törlöm, akkor nem megy a letöltés. Viszont a fájlban az van, hogy Option None. Tehát elvileg mindent tilt. Ha átírom, hogy engedjen mindent, akkor sem engedi a letöltést, csak ha törlöm. Drupal 5.7. Tud valaki valami használhatót? Előre is köszönöm!

Ja és közben megoldódott, köszi!

0
0
pp képe

Kérlek írd le a megoldást is!

pp

0
0