Áthelyezés alkönyvtárból a domain gyökerébe

Anonymous képe

Üdv!

Sikerült végre úgy-ahogy belőnöm mindent. Eddit a www.mydomain.hu/drup könyvtár volt az alap. Szeretném most áttenni az egészet a www.mydomain.hu alá. Ehhez elég, ha a fileokat átmásolom agyökérbe és a settings.pgp -ben megadom alapkönyvtáként a www.mydomain.hu -t? Vagy mást is át kell állítani?

Anonymous képe

Nos áttettem a gyökérbe, és a settings.php-t átállítottam.

A főoldal hibátlanul megjelent, de bármire kattintok, 404-es hiba. Mit kell még teni, hogy működjön?

0
0
Illyés Edith képe

A 404-et az Apache küldi vagy a Drupal ("Az oldal nem található")? Milyen címre mutatnak a linkek?

0
0
Anonymous képe

apache küldi

0
0
Illyés Edith képe

Akkor valószínűleg az Apache Virtual Host beállításaival lesz gond. Ellenőrizd, hogy a Document Root és Directory beállítások stimmelnek-e.

0
0
Anonymous képe

A szerver nem az enyém, csak tárhelyet bérelek rajta, meg szolgáltatásokat. A rendszert nincs jogom configolni.

0
0
Illyés Edith képe

Nem világos, hogy csak az útvonal álnevek nem működnek, vagy az összes linkre 404-et ad?

.htaccess fájlt nem módosítottad a régi helyen? Például meg lehet próbálni egy friss példányt felmásolni...

0
0
Anonymous képe

A linkek pl: www.mydomain.hu/valami

a valami egy megadott álútvonal, ami meg taxonomy/term/6 mondjuk. Szóval a linkek látszólag jól vannak a kódban, de aztán mégsem találja amit keres.

0
0
zozo képe

"NO trailing slash!"
Nem maradt véletlenül a settings.php-ben a baseurl után egy "/" ?

0
0
Anonymous képe

Nem az a baj, az jól van megadva.

0
0
airzsolt képe

Nemsokára én is ebben a cipőben fogok járni. Előzetesen megnéztem a drupal adatbázis (sql) mentését és az látszik, hogy elég sok helyre beíródott az drupal alkönyvtár neve (domain/drupal). Én valószínűleg egy keresés-helyettesítéssel fogom kigyomlálni ezeket. Persze nálad lehet, hogy nem ez a probléma...

0
0
Anonymous képe

Nekem 5.1 drupal van fenn. Ha neked is, akkor gyanítom, hogy az adatbázis tartalma hasonló lesz. Hol találtál bejegyzést az alapkönyvtárról? (ha lehetek ilyen kényelmes)

0
0
airzsolt képe

http://drupal.hu/node/1530
Nekem a tinymce tette be ezer helyre, szinte mindenhová, ahol a drupalon belül linkeltem.
Az átmozgatás előtt betöltöm az lementett adatbázis scriptet (akarmi.sql) egy szövegszerkesztőbe (scite), és szépen keresésé helyettesítéssel végigmegyek rajta. A comments és node_revisons táblákban kell majd cserélgetni, ha jól emlékszem.

0
0
Gyesza képe

Én is áthelyeztem a gyökérbe a drupalt, ugyan ez a problémám, bármire kattintok, 404 es hiba ,a címlap viszont megjelenik!

Mi volt a megoldás a problémára Neked?
Légyszi segíts(etek)!
Köszönöm

0
0
zozo képe

Én amikor kényszerűségből hasonlóan áthelyeztem a drupal (5.1) mappát az ég világon semmi gond nem volt. A base_url többek közt ezért jó.

0
0
oxigeny képe

Sziasztok!

Lenne egy hatalmas gondom: áthelyeztem az eddigi alkönyvtárból a végleges helyére az oldalt (akarmi.hu/akarmi -ból akarmi.hu -ba), és az sql-ben kicserélgettem a "/akarmi/" -t "/"-re, minden be is jön frankón, aminek az adatbázisból kell jönnie, de több probléma is felmerült:

A nem adatbázisos résznél _néhol_ nem frankó a kódolás... Pl Felhasználónév helyett Felhaszn?l?n?v, de alatta a Jelszó az jó. Vagy a hírlevél feliratkozásnál Explorer alatt pl a gomb szövege "Beküldés" helyett "Bek?class=", de a többi böngésző alatt sem jelenik meg jól.

Továbbá nem tudok új tartalmat bevinni, mert ahogy megnyomom a beküldést, visszadob ugyan arra az oldalra, mintha semmi sem történne, és nem is történik.

Pedig hangsúlyozom, hogy minden file-t egy az egyben átraktam, ugyan arról a szerverről van szó, csak másik könyvtár, a .htaccess fileok azok ugyan azok, az sql-ben pedig cserével kicseréltem minden alkönyvtáras hivatkozást nem alkönyvtárasra. UTF8 volt és UTF8-ként is importáltam be (de egyébként az adatbázissal nincs is baj). A .po fileok is UTF8-ak, de az alkönyvtárban még működött, utána pedig nem nyúltam hozzá. És ráadásul tegnap este még működött minden, mára pedig nem megy.

Történetesen a www.offline.hu -ról van szó.

A segítséget és az ötletelet előre is köszönöm!

0
0
Illyés Edith képe

Megnéztem az oldalt, nekem teljesen rendben lévőnek tűnik (FF2, IE7).

0
0
oxigeny képe

Megoldódott...újra be kellett auto importálni a nyelvi fájlokat! Edit köszönöm a választ! :)

üdv

0
0