Biztonsági figyelmeztetések

OpenLucius - Moderately Critical - Multiple vulnerabilities - SA-CONTRIB-2017-004

Biztonsági figyelmeztetések (contrib) - 2017. január 11. 17.23
Description

OpenLucius is a work management platform for social communication, documentation, and projects.

The distribution doesn't sufficiently use tokens when marking messages for users as read thereby exposing a Cross Site Request Forgery (CSRF) vulnerability.

The distribution does not sufficiently filter taxonomy term names before outputting them to HTML thereby exposing a Cross Site Scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have permissions to insert malicious taxonomy terms.

CVE identifier(s) issued
  • A CVE identifier will be requested, and added upon issuance, in accordance with Drupal Security Team processes.
Versions affected
  • Openlucius 7.x-1.x versions prior to 7.x-1.6.

Drupal core is not affected. If you do not use the contributed OpenLucius News module, there is nothing you need to do.

Solution

Install the latest version:

Also see the OpenLucius News project page.

Reported by Fixed by Coordinated by Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at https://www.drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.

Follow the Drupal Security Team on Twitter at https://twitter.com/drupalsecurity

Drupal version: Drupal 7.x

Autocomplete Deluxe - Moderately Critical - Cross Site Scripting (XSS) - SA-CONTRIB-2017-003

Biztonsági figyelmeztetések (contrib) - 2017. január 11. 16.42
Description

This module creates a new widget for taxonomy fields based on JQuery UI autocomplete.

The module doesn't sufficiently escape the entered taxonomy terms thereby exposing a Cross Site Scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have the permission to edit a taxonomy field.

CVE identifier(s) issued
  • A CVE identifier will be requested, and added upon issuance, in accordance with Drupal Security Team processes.
Versions affected
  • Autocomplete Deluxe 7.x-2.x versions prior to 7.x-2.2.

Drupal core is not affected. If you do not use the contributed Autocomplete Deluxe module, there is nothing you need to do.

Solution

Install the latest version:

Also see the Autocomplete Deluxe project page.

Reported by Fixed by Coordinated by Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at https://www.drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.

Follow the Drupal Security Team on Twitter at https://twitter.com/drupalsecurity

Drupal version: Drupal 7.x

Doubleclick for Publishers (DFP) - Moderately Critical - Multiple vulnerabilities - SA-CONTRIB-2017-002

Biztonsági figyelmeztetések (contrib) - 2017. január 4. 20.25
Description

This module enables you to to place advertisements on your site that are served by Google's DFP (Doubleclick for Publisher) service.

The module has multiple Cross Site Scripting (XSS) vulnerabilities due to not sufficiently escaped fields.

The "administer DFP" permission is not marked as restricted.

CVE identifier(s) issued
  • A CVE identifier will be requested, and added upon issuance, in accordance with Drupal Security Team processes.
Versions affected
  • DFP 7.x-1.x versions prior to 7.x-1.5.

Drupal core is not affected. If you do not use the contributed Doubleclick for Publishers (DFP) module, there is nothing you need to do.

Solution

Install the latest version:

Also see the Doubleclick for Publishers (DFP) project page.

Reported by Fixed by Coordinated by Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at https://www.drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.

Follow the Drupal Security Team on Twitter at https://twitter.com/drupalsecurity

Drupal version: Drupal 7.x

Permissions by Term -- Critical - Multiple vulnerabilities - SA-CONTRIB-2017-001

Biztonsági figyelmeztetések (contrib) - 2017. január 4. 19.07
Description

The Permissions by Term module extends Drupal functionality by restricting access to single nodes via taxonomy terms. Taxonomy terms are part of the Drupal core functionality. Taxonomy term permissions can be coupled to specific user accounts and/or user roles.

Enabling the module unintentionally gives access to all unpublished nodes to anonymous users

CVE identifier(s) issued
  • A CVE identifier will be requested, and added upon issuance, in accordance with Drupal Security Team processes.
Versions affected
  • Permissions by Term 8.x-1.x versions prior to 8.x-1.11.

Drupal core is not affected. If you do not use the contributed Permissions by Term module, there is nothing you need to do.

Solution

If you use the Permissions by Term module for Drupal 8.x, upgrade to Permissions by Term 8.x-1.11.

Also see the Permissions by Term project page.

Reported by Fixed by Coordinated by Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at https://www.drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.

Follow the Drupal Security Team on Twitter at https://twitter.com/drupalsecurity